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 Este documento é um guia rápido que se aplica à versão 9.1 do Quartus(R) II para a plataforma 

Windows da Microsoft, no intuito de facilitar o aprendizado dos alunos num primeiro contato com 

essa ferramenta. 

 Este tutorial será apresentado utilizando um simples circuito digital, cujo objetivo é 

apresentar alguns dos comandos mais básico do software Altera Quartus(R) II 9.1, que possui um 

simulador incorporado. Essa tarefa será realizada passo a passo. 

1. Problema proposto 

 Deseja-se montar e simular o circuito digital, utilizando portas lógicas discretas, representado 

pela expressão booleana: 

 (       )   ̅ ̅   ̅ ̅ ̅    ̅ , 

utilizando-se a ferramenta Quartus(R) II versão 9.1 da Altera. 

 A figura 1 mostra o circuito lógico obtido da expressão booleana anterior e, foi desenhado 

utilizando-se o software Quartus(R) II 9.1. O objetivo deste tutorial é reproduzi-lo, passo a passo da 

forma mais simples possível. 

 

Figura 1 - Circuito da expressão F(A,B,C,D) modelado no Quartus
(R)

 II 9.1. 

 Certifique-se de que o Altera Quartus(R) II versão 9.1 esteja instalado e pronto para uso no seu 

microcomputador. 
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Passo 1: Iniciando o Quartus(R) II 

 Localize o ícone de partida do Quartus(R) II na área de trabalho do Windows, dê duplo clique 

ou selecione-o com um clique do mouse em seguida pressione a tecla ENTER, ou um clique se o 

mesmo estiver na barra de ferramentas. Veja as figuras 2 e 3: 

 

 

Figura 2 - Ícone de partida do Altera Quartus II 9.1 Web Edition na área de trabalho do Windows. 

 

Figura 3 - Ícone de partida do Altera Quartus II 9.1 Web Edition na barra de ferramenta do Windows. 

 No caso do ícone não estar na área de trabalho, siga um dos roteiros a seguir: 

Em Português: 

 Iniciar -> Todos os Programas -> Altera -> Quartus II 9.1 Web Edition -> Quartus II 9.1 Web 

Edition (ENTER ou clique simples). 

Em Inglês: 

 Start -> All Programs -> Altera -> Quartus II 9.1 Web Edition -> Quartus II 9.1 Web Edition 

(ENTER ou clique simples). 

 Se aparecer uma janela intitulada Getting Started With Quartus(R) II Software, então clique 

com o botão esquerdo do mouse no "X" localizado no canto superior direito, para fechá-la. Aguarde a 

janela de Splash sumir e o Quartus(R) II estará pronto para o uso. 
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Passo 2: Criando um Projeto Digital Novo 

 Criaremos um projeto para o circuito apresentado na figura 1. O nome deste projeto será 

tutorial. 

 File -> New Project Wizard... (na janela New Project Wizard: Introduction) -> Next >; 

Aparecerá uma sequência de cinco páginas numeradas, mas não será necessário preencher 

todas neste tutorial. Para cancelar a criação do projeto, em qualquer momento, basta clicar no botão 

Cancel da página corrente. 

Preencha os campos necessários ao projeto nas páginas conforme indicado nas linhas que se 

seguem: 

 Tela 1 de 5: New Project Wizard: Directory, Name, Top-Level Entity 

 Na primeira caixa de texto, clique no botão ( ) para escolher uma pasta onde será 

criado o seu projeto, na segunda caixa de texto digite tutorial para o nome do projeto 

e, a terceira será automaticamente preenchida com o texto digitado na segunda caixa 

de texto, mas poderá ser alterado. Em nosso caso, aceitaremos o mesmo nome dado 

ao projeto (tutorial). Veja a imagem  na figura 4: 

 

; 
Figura 4: Tela 1 da criação de projeto 

 

 Pressione no botão Next > para avançar; 

 Tela 2 de 5: New Project Wizard: Add Files 

 Não será inserido arquivo externo, então pressione em Next > para avançar; 

 Página 3 de 5: New Project Wizard: Family & Device Settings  

 Aqui é possível selecionar o FPGA a ser utilizado no projeto durante a sua criação. 

Mas, esta opção será mostrada mais adiante no Passo 4 deste tutorial; 

 Pressione em Next > para avançar; 

 Página 4 de 5: New Project Wizard: EDA Tool Settings 

 Ignore esta página e pressione em Next > para avançar; 

 Página 5 de 5: New Project Wizard: Summary 

 Esta página contém um resumo das configurações feitas anteriormente para o projeto 

sendo criado; 

 Pressione em Finish para concluir a criação do projeto. 
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Passo 3: Criando o arquivo para o circuito digital do projeto 

 Um projeto criado no Quartus(R) II 9.1, normalmente estará vazio, entretanto, deveremos criar 

os módulos que o compõe. Nesta seção prepararemos o ambiente de desenvolvimento para receber 

o circuito digital que será simulado. Para isto execute os comandos a seguir: 

 File -> New (Aparecerá uma janela intitulada New); 

 Design Files -> Block Diagram/Schematic File -> OK, note que a área á direita da janela 

principal do Quartus(R) II aparecerá com uma grade de pontos (esses pontos são utilizados 

como coordenadas da tela para a disposição dos diversos componentes que constituem o 

circuito digital). 

 Na margem esquerda da área de desenho há uma régua vertical com alguns botões, que 

disponibilizam as opções de projeto tais como a biblioteca dos componentes, caixa de edição de 

texto, lupa para zoom etc. Vide figura 5. 

 

Figura 5 - Régua de ferramentas de desenvolvimento do Quartus
(R)

 II 9.1. 
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Passo 4: Escolhendo o FPGA a ser usado no projeto 

 Para especificar o FPGA que será usado no projeto execute as seguintes  instruções: 

 Assignments -> Device... (Aparecerá a janela Settings); então selecione: 

 (Category: Device) -> (Family: MAX7000S) -> (Available devices: Name: EPM7128SLC84-15) -> 

OK (Este chip FPGA foi selecionado porque é o que tem no Laboratório Digital). 

Para verificar qual é o FPGA sendo usado no projeto, basta observar a região Project 

Navigator: Entity, normalmente localizado à esquerda do ambiente do Quartus(R) II 9.1. Veja a figura 

6. 

 

Figura 6 – Project Navigator: Entity com o FPGA selecionado. 

  

Passo 5: Colocando os componentes na área de desenho 

 Utilize a figura 1 como referência, se necessário. 

 Execute uma das sequências de comandos abaixo para abrir a janela Symbol contendo a 

biblioteca dos diversos componentes disponibilizados pelo Quartus(R) II 9.1. 

 [Botão direito do mouse, na área de desenho] -> Insert -> Symbol... ou; 

 [Botão direito do mouse, na área de desenho] -> Insert -> Symbol as Block... ou;  

 Clique no botão com o desenho de uma porta lógica ( ), localizado na régua de 

ferramentas da figura 5. 

 Na janela Symbol, execute a sequência de comandos: 

 Se você desejar mais de uma cópia do componente selecionado, então ative o recurso (

), caso contrário mantenho-o desativado ( ). Este recurso estando 

ativado não nos impede de colocar apenas uma cópia do componente desejado na área de desenho, 

bastando para isto pressionar a tecla [ESC] ou executando a sequência de comandos com o mouse: 

[Botão direito do mouse] -> Cancel. 
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 Vamos colocar os componentes necessários ao nosso exemplo na área de desenho. Para isto, 

execute os comandos a seguir: 

 Uma porta lógica AND de duas entradas: 

 ( ) -> Libraries -> [+] c:/altera/91/quartus/libraries/ -> [+] Primitives -> [+] logic -> 

and2 -> OK -> [Botão esquerdo do mouse] 

 Duas portas lógicas AND de três entradas: 

 ( ) -> Libraries -> [+] c:/altera/91/quartus/libraries/ -> [+] Primitives -> [+] logic -> 

and3 -> OK -> [Botão esquerdo do mouse] 

 Uma porta lógica OR de três entradas: 

 ( ) -> Libraries -> [+] c:/altera/91/quartus/libraries/ -> [+] Primitives -> [+] logic -> or3 

-> OK -> [Botão esquerdo do mouse] 

 Quatro portas inversoras NOT: 

 ( ) -> Libraries -> [+] c:/altera/91/quartus/libraries/ -> [+] Primitives -> [+] logic -> not 

-> OK -> [Botão esquerdo do mouse] 

 Quatro pinos INPUT para as entradas A, B, C e D: 

 ( ) -> Libraries -> [+] c:/altera/91/quartus/libraries/ -> [+] Primitives -> [+] pin -> input 

-> OK -> [Botão esquerdo do mouse] 

 Um pino OUTPUT para a saída FIBO: 

 ( ) -> Libraries -> [+] c:/altera/91/quartus/libraries/ -> [+] Primitives -> [+] pin -> 

output -> OK -> [Botão esquerdo do mouse] 

Arraste o pino OUTPUT para próximo da saída da porta lógica or3, conforme figura 1. 

 Vamos girar os quatro pinos de entrada INPUT em 270o, de modo que fiquem com a 

extremidade "pontiaguda" para baixo, vide figura 1. Para isto, selecione um pino de cada vez 

(clicando com o mouse sobre ele) e execute os seguintes passos: 

 [Botão direito do mouse] -> Rotate by Degrees -> 270 

Repita a operação anterior para girar os quatro inversores em 270o. 

 Agora reorganize todos os componentes na área de desenho, de modo a ficarem dispostos 

como na figura 1. Pronto, então salve o projeto em disco, conforme descrito no Passo 6. 
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Passo 6: Salvando o projeto em disco 

 É uma boa prática de desenvolvimento salvar, frequentemente, o projeto ao longo de seu 

desenvolvimento. Execute os comandos a seguir: 

 File -> Save -> (Save as type: Block Diagram/Schematic File (*.bdf)) -> (File Name: tutorial) -> 

(Save in: Tutorial) -> Save. 

 

Passo 7: Dando nomes aos componentes 

 Para dar nome a um componente basta dar duplo clique sobre o componente desejado e 

seguir os passos (use a figura 1 como referência, se necessário): 

 Pinos de entrada: D, C, B, A. 

 Pin name(s): D -> OK (Na janela "Pin Properties"). 

 Pin name(s): C -> OK (Na janela "Pin Properties"). 

 Pin name(s): B -> OK (Na janela "Pin Properties"). 

 Pin name(s): A -> OK (Na janela "Pin Properties"). 

 Pino de saída: FIBO 

 Pin name(s): FIBO -> OK (Na janela "Pin Properties"). 

 Não será necessário mudar os nomes das portas lógicas, mas os procedimentos são os 

mesmos. 

 

Passo 8: Conectando os diversos componentes 

 Conectar os componentes do circuito (veja a figura 1) é muito simples, bastando para isto 

posicionarmos o ponteiro do mouse sobre o terminal desejado do componente de origem, pressionar 

o botão esquerdo, mantê-lo pressionado e arrastar até o ponto ou terminal desejado do componente 

destino, soltando-o em seguida. O aspecto do ponteiro do mouse será uma cruz com o desenho Fio 

simples, vide figura 5. 

Lembrete: É boa prática de desenvolvimento usando computador SEMPRE salvar o arquivo em disco, 

para prevenir contra uma eventual queda de energia ou pane na máquina. 

 

Passo 9: Salvando  o arquivo do circuito 

Execute: 

File -> Save 
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Passo 10: Compilando o projeto 

 Uma vez terminado o desenho do circuito, devemos compilá-lo, para em seguida fazermos a 

simulação. A compilação é feita seguindo-se os passos abaixo: 

 Processing -> Start Compilation, ou um clique no botão indicado na figura 7, da barra de 

ferramentas do Quartus(R) II 9.1. 

 

Figura 7 - Barra de ferramentas do Quartus
(R)

 II 9.1, destacando o botão de compilação. 

 Durante a compilação diversos relatórios são gerados e mantidos à disposição do usuário. 

 

Passo 11: Criando a Simulação do projeto 

 Execute os comandos a seguir, para criar uma simulação: 

 File -> New -> [+] Verification/Debugging Files -> Vector Waveform File -> OK 

 Neste momento um arquivo que conterá os dados da simulação será criado e uma janela 

própria da ferramenta de simulação do Quartus(R) II 9.1 será aberta e ficará pronta para uso. Essa 

janela é dividida em quatro partes:  

 Régua de ferramentas para as configurações da simulação;  

 Régua com as bases de tempo;  

 Coluna para os nomes dos pontos de teste com a base de tempo e;  

 Área das cartas de tempo (timing chart) do circuito. 

 

Passo 12: Salvando a simulação 

 Salve o arquivo de simulação com o mesmo nome do projeto, ou seja, tutorial. Para isto 

execute a sequência de comandos a seguir: 

 File -> Save -> (Save as type: Vector Waveform File (*.vwf)) -> (Save in: Tutorial) -> (File name: 

tutorial) -> Save 
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Passo 13: Incluindo os pontos de teste para a Simulação 

 Clique o botão direito do mouse sobre a região dos pontos de teste do circuito simulado 

(colunas: Name e Value at). Veja a figura 8: 

 

 

Figura 8 – Área destinada à declaração dos pontos de teste do circuito. 

 Podemos entrar com um ponto de teste de cada vez ou um conjunto, dentre os disponíveis, 

em uma operação só. Veremos os dois jeitos: 

 Entrando um ponto de teste por vez: 

 [Botão Diteiro do Mouse] -> Insert -> Insert Node or Bus... -> (Name: A) -> OK 

 Entrando um conjunto dentre ospontos de teste disponíveis ou todos de uma só vez:  

 [Botão Diteiro do Mouse] -> Insert -> Insert Node or Bus... -> Node Finder... -> (Named: *) -> 

(Filter: Pins: All) -> List -> [>>] -> OK -> OK 

 

Passo 14: Determinando os sinais dos pontos de teste para simulação 

 No nosso caso temos cinco pontos de teste, isto é, quatro variáveis de entrada (D, C, B, A) e 

uma de saída (FIBO), então configuraremos os sinais das entradas conforme disposto numa tabela 

verdade de quatro variáveis, onde 0 indica nível lógico zero e 1 indica nível lógico um. Veja a figura 9. 

 

Figura 9 - Variáveis de entrada/saída para análise da simulação do projeto. 

  

  

Clique Aqui 
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Siga os passos abaixo: Utilize a região das variáveis, vide figura 9: 

 Variável A (linha 0): [Clique no desenho ] ->  -> (Radix: Binary) ->Timing -> 

(Multiplied by: 1) -> OK 

 Variável B (linha 1): [Clique no desenho ] ->  -> (Radix: Binary) ->Timing-> 

(Multiplied by: 2) -> OK 

 Variável C (linha 2): [Clique no desenho ] ->  -> (Radix: Binary) ->Timing-> 

(Multiplied by: 4) -> OK 

 Variável D (linha 3): [Clique no desenho ] ->  -> (Radix: Binary) Timing->-> 

(Multiplied by: 8) -> OK 

 Deixe a variável FIBO com a configuração original. 

 

Passo 15: Configurando a simulação  

 O Altera Quartus(R) II 9.1 tem três modos de simulação: Functional; Timing e; Timing using Fast 

Timing Model. 

O default é o modo Timing que considera os atrasos internos do tempo no FPGA  e será aqui 

adotado.  

Na seção Outras Informações é apresentado como proceder para configurar o modo de 

simulação Functional. 

Vamos configurar o instante final (End Time) e a largura da grade de tempos (Grid Size) da 

simulação. Clique na aba tutorial.vwf, para trazer a sua janela ao primeiro plano do ambiente de 

desenvolvimento. 

 Edit -> End Time... -> (Time: 1.0 µs) -> OK (Para podermos analisar melhor o comportamento 

do circuito) 

 Edit -> Grid Size… -> (Period: 40.0 ns) -> OK 

Lembrete: Salve o arquivo com a sequência de teclas [Ctrl+S] ou executando os comandos do Passo 

12. 

Passo 16: Executando a simulação  

 A simulação pode ser iniciada por três caminhos diferentes: 

1. Clique na aba [Quartus II] -> Simulator Tool -> Start -> OK (Janela de Diálogo informando o 

resultado da compilação) -> Report; 

2. Processing -> Start Simulation -> OK (Janela de Diálogo informando o resultado da 

compilação) e; 

3. Através da régua de ferramentas, conforme indicado na figura 10:  
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Caso a simulação tenha sido iniciada a partir do menu (caminho 1) ou pressionando-se o botão em 

destaque na figura 10 (caminho 3), então poderemos visualizar os relatórios (inclusive a carta de 

tempos) executando a sequência de comandos: Processing -> Simulation Report, ou pelo atalho 

[Ctrl+Shift+R]. 

       A figura 10 mostra o botão da barra de ferramentas usado para executar a simulação. 

 

Figura 10 - Botão para iniciar a simulação no Simulador do Quartus
(R)

 II 9.1. 

 O resultado da simulação é mostrado na figura 11: 

 

Figura 11 – Carta de tempos (Timing Chart) da simulação no modo Timing. 

Note que o FPGA escolhido (MAX7000S – EPM7128SLC84-15) apresenta atraso significativo no 

pino de saída em relação aos pinos de entrada.  

 

 

OUTRAS INFORMAÇÕES 

1. Abrindo um Projeto Já Existente 

Devemos apenas carregá-lo, executando os comandos a seguir: 

 File -> Open Project... -> Files of type: Quartus II Project File (*.qpf; *.quartus; *.quar) -> Look 

in: Tutorial -> File name: tutorial -> Open 

A figura 12 mostra como podemos identificar o projeto carregado e o FPGA selecionado para 

o mesmo: 
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Figura 12: projeto carregado e FPGA selecionado 

Para carregar o arquivo com o circuito digital dê duplo clique no Nome do projeto corrente, 

conforme mostrado na figura 12 

 

2. Utilizando um Arquivo com Circuito Digital já Editado (*.dbf) 

Para utilizar um arquivo de circuito digital já editado (*.dbf) em um projeto novo, execute os 

comandos a seguir: 

Criaremos um projeto para o circuito apresentado na figura 1. O nome deste projeto será 

tutorial2 e o arquivo do circuito digital é circuito.dbf. 

 File -> New Project Wizard... (na janela New Project Wizard: Introduction) -> Next >; 

Aparecerá uma sequência de cinco páginas numeradas, mas não será necessário preencher 

todas neste tutorial. Para cancelar a criação do projeto, em qualquer momento, basta clicar no botão 

Cancel da página corrente. 

Preencha os campos necessários ao projeto nas páginas conforme indicado nas linhas que se 

seguem: 

 Página 1 de 5: New Project Wizard: Directory, Name, Top-Level Entity 

 Na primeira caixa de texto, clique no botão ( ) para escolher uma pasta onde será 

criado o seu projeto, na segunda caixa de texto digite tutorial2 para o nome do 

projeto e, a terceira deverá ser preenchida com o nome do arquivo do circuito digital a 

ser aproveitado (circuito.dbf). Veja a imagem na figura 13. 

 Pressione no botão Next > para avançar; 
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; 

Figura 13: criação de projeto novo com inclusão do arquivo do circuito editado 

 

 Página 2 de 5: New Project Wizard: Add Files 

 Não será inserido arquivo externo, então pressione em Next > para avançar; 

 Página 3 de 5: New Project Wizard: Family & Device Settings  

 Aqui é possível selecionar o FPGA a ser utilizado no projeto durante a sua criação. 

Mas, esta opção será mostrada mais adiante no Passo 4 deste tutorial; 

 Pressione em Next > para avançar; 

 Página 4 de 5: New Project Wizard: EDA Tool Settings 

 Ignore esta página e pressione em Next > para avançar; 

 Página 5 de 5: New Project Wizard: Summary 

 Esta página contém um resumo das configurações feitas anteriormente para o projeto 

sendo criado; 

 Pressione em Finish para concluir a criação do projeto. 

 Copie o arquivo circuito.dbf para o diretório do novo projeto (Tutorial2). 

 

 

3.  Configurando o Modo da Simulação Funcional 

 Para mudar o modo de simulação execute a sequencia de comando, a seguir: 

 Processing -> Simulator Tool. Veja a figura 14.  

 

Para configurar o modo Funcional, deve-se preencher o modo de simulação com Functional. A figura 

7 , mostra esta configuração. 
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Figura 14 – modo Funcional. 

 Note que no modo Functional o botão [Generate Functional Simulation Netlist] ficou ativo e 

esse deve ser pressionado, para que a simulação neste modo funcione corretamente. Então, a 

próxima sequência de comandos a ser seguida é: 

 Clique em [Generate Functional Simulation Netlist] -> OK -> Start -> OK -> Report 

O resultado da simulação é mostrado na figura 15: 

 

Figura 15 – Carta de tempos (Timing Chart) da simulação no modo Functional. 

 Compare as cartas de tempo das figuras 12 e 16. Observe a diferença clara entre os resultados 

das simulações nos modos Timing e Functional. 

Conclusão: 

 Este tutorial procurou iniciar o usuário no Altera Quartus(R) II 9.1 passo a passo, de forma 

bastante simples, de modo que o mesmo possa se aperfeiçoar, por conta própria, a partir deste 

ponto. 
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